Resolved: We have fully resolved the issue affecting automated Google Ads budget updates. Beginning June 26, a change to how the Google Ads API handles certain high-volume reporting queries caused delays in automated budget pacing updates for some accounts. Our engineering team identified the root cause and rolled out a series of updates to align with Google's new API requirements. All automated budget syncing and pacing is now operating normally. We appreciate your patience throughout this process and apologize for any disruption this may have caused to your campaigns.
Posted Jul 01, 2026 - 13:47 UTC
Update
A recent change on Google's side affected how their advertising API handles larger data requests. As a result, the volume of data Shape was retrieving for each budget campaign update became significantly more costly to process, which caused Google Ads spend data to update less frequently than normal for a period. This change specifically was impacting token level quota limits, and in some cases, this could have delayed automated budget pacing.
We've streamlined how Shape requests Google Ads data so it's pulled far more efficiently, and Google Ads spend data is now updating normally again. We are actively monitoring to confirm everything stays stable.
Additional refinements to this part of the system will continue rolling out over the next several days to make it more resilient going forward. If any upcoming change is customer-impacting or requires action on your part, we'll be sure to communicate that directly.
Posted Jun 30, 2026 - 23:11 UTC
Monitoring
Update: This was caused by recent changes on Google's side to how their Ads API handles large, data-heavy reporting queries (including impression-share metrics). We're rolling out updates to align with Google's new guidance. We'll continue deploying the remaining changes over the next several days and will post another update once everything is fully back to normal.
Posted Jun 29, 2026 - 20:51 UTC
Investigating
Our team is currently investigating an issue that is preventing Shape from applying automated budget changes to some connected Google Ads accounts. We will keep you posted here as we learn more.
Posted Jun 29, 2026 - 15:53 UTC
This incident affected: Shape Platform (Shape Core Platform).