Errors loading data sources and delayed data refresh

Incident Report for NinjaCat

Resolved

This issue is now resolved. Thank you for your patience as our team worked through the fix.
Posted Aug 06, 2026 - 17:07 UTC

Monitoring

A fix has been deployed and new data requests are processing normally. We are now re-running the data fetches that failed during the impact window (Aug 5 21:30 UTC – Aug 6 HH:MM UTC). Data freshness should fully recover over the next few hours.
Posted Aug 06, 2026 - 16:12 UTC

Identified

We are aware of an issue affecting data source connections across the platform. Customers may see errors when opening or refreshing data sources — including Google Sheets and other integrations — and reports may show data that has not refreshed since approximately 21:30 UTC on August 5, 2026.

Existing reports and dashboards remain accessible; the issue affects the retrieval of new data, not previously loaded data.

Our engineering team has identified the likely cause and is actively working on a fix. Data that failed to load will be re-fetched once the fix is deployed — no action is required from you.

We'll update again within 60 minutes,Errors loading data sources and delayed data refresh or sooner if the situation changes.
Posted Aug 06, 2026 - 14:34 UTC
This incident affected: Core Platform (Reporting, Integrations).