Slow Data Processing

Incident Report for NinjaCat

Resolved

All External Data Requests have been processed, and the system is functioning at full capacity again. Thank you for your patience in this.
Posted Jan 06, 2026 - 00:53 UTC

Monitoring

We have a large backlog of data requests that are processing, which is resulting in reports and dashboards taking longer to generate. We apologize for the delay in certain data providers. We'll update here when data processing is all caught up.
Posted Jan 05, 2026 - 22:12 UTC
This incident affected: Core Platform (Reporting, Integrations, Template Builder, Dashboards).