Data requests not processing for NinjaCat

Incident Report for NinjaCat

Resolved

This incident has been resolved, as the queue of data requests and datasets continues to get caught up. We apologize for the inconvenience, and please reach out to support@ninjacat.io if you have any further issues.
Posted Mar 17, 2026 - 18:33 UTC

Monitoring

We've deployed a fix, and are monitoring the data request processing systems.
Posted Mar 17, 2026 - 14:27 UTC

Investigating

We're aware of an issue where data requests are not processing. The engineering team is investigating this, and we will keep you posted here.
Posted Mar 17, 2026 - 13:38 UTC
This incident affected: Core Platform (Reporting, Integrations, Template Builder, Dashboards).