Some dataset syncs stuck "In Progress"

Incident Report for NinjaCat

Resolved

The issue causing dataset syncs to remain stuck "In Progress" has been resolved. All affected syncs have completed and datasets are updating normally. Thank you for your patience.
Posted Jul 06, 2026 - 23:37 UTC

Monitoring

A fix has been deployed and we are re-running the affected dataset syncs. We're monitoring to confirm datasets return to normal, up-to-date syncing. Some datasets may take a short time to fully catch up.
Posted Jul 06, 2026 - 19:29 UTC

Investigating

We are aware of and investigating an issue where some scheduled dataset syncs — including Google Sheets–powered datasets — are stuck in an "In Progress" state and not completing. Affected datasets may show stale data or 0% sync progress. Existing data remains available and unaffected; only new sync updates are delayed.
Posted Jul 06, 2026 - 17:07 UTC
This incident affected: Core Platform (Reporting, Integrations, Dashboards).