This issue is now resolved, and we've confirmed that new and recently changed Google Ads campaigns are syncing normally again. Existing budgets and spend tracking were not affected at any point. Thank you for your patience.
Posted Jul 07, 2026 - 22:01 UTC
Monitoring
We've deployed a fix for the delayed campaign data and are now monitoring recovery. The issue was caused by an unusually high volume of campaign-refresh requests to the Google Ads API, which triggered a temporary rate limit and caused some refreshes to return no results. Our fix removes those redundant requests and adds safeguards so the limit is no longer being reached, and newly created and recently modified Google Ads campaigns are being retrieved and displayed normally again.
Affected accounts continued to connect and sync throughout, and existing budgets and spend tracking were not affected at any point.
We're now watching closely to confirm the fix holds and that any previously missing campaigns have caught up. If a specific campaign still isn't showing, refreshing that account in Shape will pull it in.
Thank you for your patience.
Posted Jul 07, 2026 - 19:38 UTC
Identified
We've identified an issue that can prevent some newly created or recently modified Google Ads campaigns from appearing in Shape. Affected accounts connect and sync normally, but the impacted campaigns may not show up when building or editing a budget, and may be missing from campaign lists.
The cause is a temporary limit being applied by the Google Ads API to how frequently we can retrieve campaign data, which is causing some campaign-refresh requests to return no results for affected accounts. Existing budgets and spend tracking are not affected — this is limited to the discovery of new or updated campaigns.
Our team has identified the root cause and is actively working on a fix. We'll post another update as soon as the fix is in progress or resolved.
Thank you for your patience.
Posted Jul 07, 2026 - 16:44 UTC
This incident affected: Shape Platform (Shape API, Shape Core Platform).