External data requests to 3rd party data providers are slow

Incident Report for NinjaCat

Resolved

The External Data Request processing is back to normal, and working through the backlog of data requests. We expect to be fully caught up within 30-60 minutes. Thank you for your patience as our team worked to resolve this issue.
Posted Dec 30, 2025 - 21:34 UTC

Investigating

We are aware of and working on an issue where External Data Requests to Simplifi, Centro Basis, The Trade Desk, Snowflake Share, and Smart Connectors. We will keep you updated here.
Posted Dec 30, 2025 - 18:28 UTC
This incident affected: Core Platform (Reporting, Integrations, Template Builder, Dashboards).