Reports are slow or stuck in generating.

Incident Report for NinjaCat

Resolved

All report generation is back to normal now. Thank you for your patience as we worked through this.
Posted May 20, 2025 - 15:28 UTC

Monitoring

Reports are now processing again, and the team is continuing to monitor the report generation services.
Posted May 20, 2025 - 14:45 UTC

Investigating

We are aware of an issue where some reports are either stuck, or slow to generate. The team is investigating what the root cause of this may be. We will keep you updated here as we learn more.
Posted May 20, 2025 - 14:29 UTC
This incident affected: Reporting.